Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#1009 closed bug (fixed (in master))

Crash after character birth when randarts are enabled

Reported by: MarbleDice Owned by: magnate
Milestone: 3.1.2 beta Keywords: items
Cc:

Description

The attached savefile will occasionally crash after accepting a character. Crashes on Windows XP and Vista, possibly other platforms. Doesn't seem to crash when randarts are disabled.

See http://angband.oook.cz/forum/showthread.php?p=26054

Attachments (1)

Annarri (45.9 KB) - added by MarbleDice 10 years ago.
Start a new character (quickstart is fine)

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by MarbleDice

Start a new character (quickstart is fine)

comment:1 Changed 10 years ago by magnate

  • Owner set to magnate
  • Status changed from new to assigned

Oh bother. This is a crash with randart generation then. Please zip and attach the randart.log file after a crash.

comment:2 Changed 10 years ago by MarbleDice

I can't seem to upload zip files for some reason, try downloading this:

http://www.bromleyoil.com/filehost/randart.zip (202 KB)

comment:3 Changed 10 years ago by magnate

Ok, this is desperately weird. The last entry reads: Creating tval 124 sval 0. The problem is, tval 124 doesn't exist - there is nothing in object.txt with that tval. The only thing I can think of is that it hit a boundary and overflowed from k_info, getting garbage. [9c63e05] (SVN r1768) addresses this, but I'll leave the ticket open for a while in case this doesn't fix the crash. (Please test with the *same* savefile.)

comment:4 Changed 10 years ago by MarbleDice

[9c63e05] (SVN r1768) does seem to fix the problem. The same savefile which crashed after character birth no longer crashes. You can probably count this one fixed.

comment:5 Changed 10 years ago by magnate

  • Resolution set to fixed
  • Status changed from assigned to closed

[9c63e05] (SVN r1768)

comment:6 Changed 9 years ago by magnate

  • Milestone changed from Triage to 3.1.2 beta
Note: See TracTickets for help on using tickets.