Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1010 closed bug (fixed (in master))

Ammo branded by spell doesn't show that in inventory

Reported by: noz Owned by:
Milestone: 3.1.2 beta Keywords: id
Cc:

Description

When ammo is branded by the mage spell "Elemental Brand", you get a message e.g. "A frosty aura surrounds the Arrows", but then they show up in the inventory as simply: "20 Arrows (1d4) (+5,+3)", not "20 Arrows of Frost (1d4) (+5,+3)".

When inspected, they do say: "Branded with frost.", and have the correct damage calculation.

Change History (3)

comment:1 Changed 10 years ago by magnate

Interesting. If they show up as branded on inspection, then the brand flag is getting set correctly. Which means the problem is somewhere in obj-desc, and most likely in the odesc_detail mode setting.

comment:2 Changed 10 years ago by MarbleDice

  • Resolution set to fixed
  • Status changed from new to closed

[3a64de4] (SVN r1770), calling object_notice_ego on the item after changing its ego name seems to do the trick.

comment:3 Changed 10 years ago by magnate

  • Milestone changed from Triage to 3.1.2 beta
Note: See TracTickets for help on using tickets.