Opened 9 years ago

Closed 4 years ago

#1017 closed change (fixed (in master))

Throwing from the quiver

Reported by: MarbleDice Owned by: d_m
Milestone: 4.0 Keywords: items
Cc:

Description (last modified by nckmccnnll)

Ideally you shouldn't be able to throw your gear in normal equipment slots, but you should be able to throw anything in your quiver.

Also it would be nice if the automatic quiver numbering worked for throwing ammo from your quiver as well as firing it.

Change History (11)

comment:1 Changed 9 years ago by MarbleDice

Currently an error message prevents throwing equipped gear, but it would be even better if the interface didn't present the normal equipment slots for selection when throwing. An item tester is insufficient for this purpose however because the item tester functions receive an o_ptr, and have (to my knowledge) no notion of if that item is equipped by the player.

comment:2 Changed 9 years ago by magnate

  • Milestone changed from Triage to 3.1.2 beta
  • Status changed from new to confirmed

Personally I wouldn't have any problem with being able to throw from any equipment slot, if it made it much easier to throw straight from the quiver. But if the ideal solution can be found, so much the better.

comment:3 follow-up: Changed 9 years ago by d_m

MarbleDice? made the excellent point that throwing from equipment is almost certainly an error--someone losing a potential winner because they accidentally threw Narya, or Aule, or something would be terrible.

comment:4 in reply to: ↑ 3 Changed 9 years ago by magnate

Replying to d_m:

MarbleDice made the excellent point that throwing from equipment is almost certainly an error--someone losing a potential winner because they accidentally threw Narya, or Aule, or something would be terrible.

I'm not sure I understand this - I wasn't aware that you couldn't get something back if you threw it (do things break, other than ammo and flasks?). I guess you might mean that someone could get themselves killed by throwing a vital piece of protective equipment in the middle of a fight. Ho hum. You'd only do it once!

comment:5 follow-up: Changed 9 years ago by takkaria

Hmm, not sure I agree here. The point of throwing has always been that you can just chuck stuff from your pack-- like oil, torches, potions of poison and whatnot.

comment:6 in reply to: ↑ 5 Changed 9 years ago by anonymous

Replying to takkaria:

Sorry if it wasn't clear, the current behavior is this:

  • You can throw from the pack
  • You can throw from your equipment (gear and quiver)
  • You receive an error when attempting to throw your gear

This is fine I think, but the changes that might be nice are:

  • The player should not be able to select gear (only quiver) when throwing from equipment, so no error message is necessary.
  • Quiver slot numbers should work when throwing from the quiver.

comment:7 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:8 Changed 8 years ago by magnate

  • Type changed from bug to change

comment:9 Changed 7 years ago by magnate

  • Milestone changed from 3.3.0 to Future

Punting in accordance with new milestone policy (that any other milestone is only set once someone is actually working on the ticket).

comment:10 Changed 4 years ago by nckmccnnll

  • Description modified (diff)
  • Milestone changed from Future to 4.0

Stuff can now be thrown from the quiver - using slot numbers set for 4.0

comment:11 Changed 4 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Fixed in 2048000

Note: See TracTickets for help on using tickets.