Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#1018 closed bug (fixed (in master))

Cursed ammo doesn't make sense

Reported by: MarbleDice Owned by: d_m
Milestone: 3.5.0 Keywords: items curses
Cc:

Description (last modified by takkaria)

Previously, the (sticky) curse flag on ammo served no function, since you couldn't equip it.

Currently, you cannot remove cursed ammo from your quiver. However, you can still fire it, so it is trivial to get rid of it.

Curses on ammo should either be removed completely, or you should not be able to fire, drop, throw, or unequip cursed ammo in the quiver.

I prefer removing curses on ammo. This is consistent with past behavior, and probably makes sense considering curses are scheduled to be re-worked anyway.

Change History (10)

comment:1 Changed 10 years ago by fph

In Nethack, cursed ammo has a probability to "slip" and go another random direction instead of the wanted one. This could be interesting to implement in 'band too.
Also, cursed ammo with positive +hit/+dam could be an interesting tradeoff.

comment:2 Changed 10 years ago by KZK

Cursed ammo should return to your quiver when fired (that way it's non-trivial to remove by firing). It should also heal monsters it hits, should only break infrequently when it hits a monster (1/10 the normal rate) and then return to your quiver. In returning to your quiver it should deal damage to the player. Remove curse should affect only 10% of cursed ammo.

comment:3 Changed 10 years ago by KZK

Now that we have a quiver, firing/throwing from your pack should incur an extra turn cost. Throwing/firing a cursed Item from your pack should also return it to your quiver (for throwing/firing items if that gets implemented) as equiped, forcing other things out of your quiver if all slots are full. For ammo, where there is multiple items, firing it from your pack should have the effect of equiping it, when the ammo is cursed.

comment:4 Changed 9 years ago by magnate

  • Milestone changed from Triage to 3.1.3

comment:5 Changed 9 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:6 Changed 9 years ago by magnate

  • Status changed from new to confirmed

comment:7 Changed 9 years ago by takkaria

  • Keywords curses added
  • Milestone changed from 4.0 to 3.3.0

comment:8 Changed 8 years ago by magnate

  • Milestone changed from 3.3.0 to Future

Punting in accordance with new milestone policy (that any other milestone is only set once someone is actually working on the ticket).

comment:9 Changed 6 years ago by takkaria

  • Description modified (diff)
  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

We no longer have cursed ammo.

comment:10 Changed 6 years ago by takkaria

  • Milestone changed from Future to 3.5.0

Assigning still-open bugs from Future to 3.5 for fixing.

Note: See TracTickets for help on using tickets.