Opened 9 years ago

Closed 9 years ago

#1021 closed bug (invalid)

ID-by-use doesn't work properly for Defenders

Reported by: magnate Owned by:
Milestone: 3.1.2 beta Keywords: id
Cc:

Description

http://angband.oook.cz/forum/showthread.php?t=2531 has a savefile with an already-IDd Defender which is missing the Feather Fall attribute (it was ID'd by use, and seems to have been IDd too early).

While trying to reproduce this bug I ended up with a Defender that had all attributes known except See Invis. I stepped into LOS of an invisible creature and SInv did not register. I had to take off and re-wield the Defender for it to register, and finally ID.

I think this might be two separate bugs, but until I can reproduce the first one I'm not sure.

Change History (3)

comment:1 Changed 9 years ago by magnate

Ok, I understand the second problem: I turned the weapon into a defender while I was already wielding it (using wizard mode), so the SEE_INVIS flag never registered - it's in TR2_OBVIOUS_MASK so it should register during object_notice_on_wield.

Now to try again to ID everything except FF ....

comment:2 Changed 9 years ago by magnate

No, I can't reproduce this. After long enough the item is fully IDd apropos of nothing. I had IDd all flags except rElec and FF, and it just said "Attacking monsters with: ..." and fully IDd it, including the FF.

comment:3 Changed 9 years ago by magnate

  • Resolution set to invalid
  • Status changed from new to closed

This turned out to be a result of an unclean build.

Note: See TracTickets for help on using tickets.