Opened 10 years ago

Closed 8 years ago

#1039 closed change (fixed (in master))

Make OF_LIGHT granular

Reported by: magnate Owned by: magnate
Milestone: 3.4.0 Keywords: items affixes
Cc:

Description

Buried deep in http://angband.oook.cz/forum/showthread.php?t=2454 is a sensible point that there really aren't very many artifacts for certain slots (particularly boots). There's also Paul Blay's Large Metal Shield Of The Sun, which would make a nice addition.

This should go hand-in-hand with a second round of anti-junk tweaking, following #526 and #904. If I was being really sensible I'd do it after both #1014 and #951.

Attachments (1)

ofthesun.patch (8.0 KB) - added by magnate 9 years ago.
Paul Blay's patch for the Large Metal Shield of the Sun (needs updating)

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by anonymous

I suggest looking through the Silmarillion to find artifacts. I remember seeing somethings that were'nt in Angband.

comment:2 Changed 9 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:3 Changed 9 years ago by magnate

  • Milestone changed from 4.0 to 3.4.0

Changed 9 years ago by magnate

Paul Blay's patch for the Large Metal Shield of the Sun (needs updating)

comment:4 Changed 8 years ago by magnate

  • Status changed from new to assigned
  • Summary changed from A few new artifacts to Make OF_LIGHT granular

[r2744ef5] adds two new pairs of boots and a wicker shield. Leaving this ticket open for the Large Metal Shield of the Sun, which needs OF_LIGHT to become a pval flag.

comment:5 Changed 8 years ago by magnate

  • Keywords affixes added
  • Status changed from assigned to pending

http://github.com/angband/angband/pull/94. Still need to put in the Sun shield though.

comment:6 Changed 8 years ago by magnate

Added in [rc7408fb]

comment:7 Changed 8 years ago by magnate

  • Milestone changed from 3.4.0 to 4.0

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:8 Changed 8 years ago by magnate

  • Milestone changed from 4.0 to 3.4.0
  • Resolution set to fixed (in master)
  • Status changed from pending to closed

finally sorted in [r90a1e18]. In case anyone is interested, this was the last change before the v4 fork.

Note: See TracTickets for help on using tickets.