Opened 9 years ago

Closed 7 years ago

#1050 closed change (fixed (in v4))

Finer controll for item squelch

Reported by: Tobias Owned by: magnate
Milestone: v4 Keywords: squelch affixes
Cc:

Description

It might be good to have some more squelch options.
Especially one that squelches boots of stealth, but leaves boots of speed unsquelched.

Possibly even a option that lets you squelch individual egos.

Change History (9)

comment:1 Changed 9 years ago by anon

Personally, I much prefer NPP's squelch system.

comment:2 Changed 9 years ago by MarbleDice

Ego squelch could be quite useful, another one that I have wanted is pval squelch for those Rings of Constitution +2.

comment:3 Changed 9 years ago by MarbleDice

  • Keywords squelch added
  • Milestone changed from Triage to 3.1.3
  • Type changed from bug to change

comment:4 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:5 Changed 7 years ago by magnate

  • Keywords squelch,affixes added; squelch removed
  • Owner set to magnate

This ticket is addressed in (or enabled by) https://github.com/angband/angband/pull/94

comment:6 Changed 7 years ago by magnate

  • Milestone changed from 4.0 to 3.4.0
  • Status changed from new to confirmed

This needs testing but ego squelch should now allow the squelching of any affix. We just need to make sure that the squelch marker isn't set unless *all* affixes on an item are squelched.

comment:7 Changed 7 years ago by magnate

  • Milestone changed from 3.4.0 to 4.0

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:8 Changed 7 years ago by magnate

  • Keywords squelch affixes added; squelch,affixes removed
  • Status changed from confirmed to assigned

Ok, my initial plan for this is simple: you choose to squelch or not squelch each individual affix. If all the affixes on an item are set to squelched, then the item is squelched. If not, it's not.

After that we can see about getting more sophisticated.

comment:9 Changed 7 years ago by magnate

  • Resolution set to fixed (in v4)
  • Status changed from assigned to closed

[rb958582]

Note: See TracTickets for help on using tickets.