Opened 10 years ago

Closed 10 years ago

#1055 closed bug (fixed (in master))

Ring of Escaping and (+4 to speed) display

Reported by: SilverD Owned by: MarbleDice
Milestone: 3.1.2 beta Keywords:
Cc:

Description

I found a Ring of Escaping, and I already know all of its bonuses - like +4 to speed, and thus, I can't use ID on it.
However, when I sell it to a store, it becomes Ring of Escaping (+4 to speed). When I buy it back, it stays that way.

Kind of weird. Maybe remove the (+4 to speed) in the name altogether, since I don't think it can be anything else other than +4?

Change History (3)

comment:1 Changed 10 years ago by Tobias

Rings of Teleport have the same problem.
You can't cast identify on it either.
You can stack id them too.

The problem is that the description says 'affects your speed' if you have the half ided version.

comment:2 Changed 10 years ago by MarbleDice

  • Owner set to MarbleDice
  • Status changed from new to assigned

The problem here is that the pval isn't always visible on jewelry with non-variable pvals. Patch incoming.

comment:3 Changed 10 years ago by MarbleDice

  • Resolution set to fixed
  • Status changed from assigned to closed

[f0d86ee] (SVN r1869)

Note: See TracTickets for help on using tickets.