Opened 9 years ago

Closed 9 years ago

#1056 closed bug (fixed (in master))

Strange display errors

Reported by: Tobias Owned by: MarbleDice
Milestone: 3.1.2 beta Keywords: display
Cc:

Description

When i display the equipment list on the main screen, the name of one item is cut off. See pictures.

like:

On feet: The Pair                      4% fail

It happens with e I and A buttons.
It does not happen with inventory display or with subwindow.

I am using the sdl version. My version is R 1869, but I think the bug has been there for some time.

Attachments (2)

activate.png (6.8 KB) - added by anonymous 9 years ago.
examine.png (16.9 KB) - added by Tobias 9 years ago.
Screenshot of the examine display

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by anonymous

Changed 9 years ago by Tobias

Screenshot of the examine display

comment:1 Changed 9 years ago by MarbleDice

  • Keywords display added
  • Milestone changed from Triage to 3.1.2 beta

This is pretty strange. The slot that gets truncated moves around... Do the names always cut truncated at the 10th character, or does that vary too? ("The Pair" could be 9th or 10th character due to the space)

comment:2 Changed 9 years ago by Tobias

I have looked some more:
It is always after the 9th character.
It seems to be triggered by long names (like my crown of Gondor). If the previous item is to long for the line the next item gets cut off.

comment:3 Changed 9 years ago by MarbleDice

  • Owner set to MarbleDice
  • Status changed from new to assigned

I still can't reproduce this, but [b8a1e25] (SVN r1874) introduces a truncation fix for long object names. Does that happen to fix the problem for you?

comment:4 Changed 9 years ago by Tobias

Yes, fixed in [b8a1e25] (SVN r1874).
Thanks.

comment:5 Changed 9 years ago by MarbleDice

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.