Opened 10 years ago

Closed 9 years ago

#1057 closed bug (worksforme)

Crash when running into space adjacent to dungeon edge

Reported by: MarbleDice Owned by:
Milestone: 3.2.0 Keywords: player
Cc:

Description (last modified by MarbleDice)

Affects HEAD as early as [0463b2c] (SVN r1867), affected platforms include Windows XP.

Crashes when the player runs into a tile that is adjacent to the permanent wall edge of the dungeon map from a tile that is not adjacent to the edge. Does not appear to happen with the north dungeon wall.

See http://angband.oook.cz/forum/showthread.php?t=2679

Attachments (3)

ariel.zip (9.5 KB) - added by MarbleDice 10 years ago.
Savefile. Run south.
Faust_I.zip (15.1 KB) - added by MarbleDice 10 years ago.
Savefile.
wallcrash.jpg (7.1 KB) - added by Faust 10 years ago.
Error message given when running into wall.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by MarbleDice

Savefile. Run south.

Changed 10 years ago by MarbleDice

Savefile.

Changed 10 years ago by Faust

Error message given when running into wall.

comment:1 Changed 10 years ago by MarbleDice

  • Description modified (diff)

Fixed the thread link.

comment:2 Changed 10 years ago by anonymous

Possibly related #985, closed due to inability to reproduce.

comment:3 Changed 10 years ago by magnate

  • Keywords player added; crash cleanup removed
  • Status changed from new to confirmed

possibly fixed in [94d1dca] (SVN r1887)

comment:4 Changed 9 years ago by takkaria

won't have been fixed in [94d1dca], it'll be as a result of the running change to stop a grid before (sleeping) monsters.

comment:5 Changed 9 years ago by magnate

  • Status changed from confirmed to pending

I can no longer reproduce this bug, with either attached savefile (or my own). Marking as pending until someone else tests.

comment:6 Changed 9 years ago by magnate

  • Resolution set to worksforme
  • Status changed from pending to closed

Considered no longer extant as of http://bit.ly/gQGEo9

Note: See TracTickets for help on using tickets.