Opened 8 years ago

Closed 3 years ago

#1068 closed task (fixed (in master))

Get rid of item_tester_unknown in spells2.c

Reported by: Tobias Owned by: MarbleDice
Milestone: Future Keywords: id
Cc:

Description (last modified by nckmccnnll)

MarbleDice fixed the original bug, but item_tester_unknown is now a nest of hacks. Once the refactoring is complete it should be removed, unless the object structure is going to be totally re-done, i.e. complete change or removal of the bitflag mechanic.

Setting to 3.3 for consideration after refactoring.

Change History (7)

comment:1 Changed 8 years ago by MarbleDice

  • Keywords identify added
  • Milestone changed from Triage to 3.1.2 beta
  • Status changed from new to confirmed

I believe this was introduced in [d24441f] (SVN r1876), and happens because identify.c's object_is_not_known_consistently() returns TRUE for stat rings when it should not. Not sure what the fix is at the moment, but it shouldn't be too hard.

comment:2 Changed 8 years ago by MarbleDice

  • Milestone changed from 3.1.2 beta to 3.1.3
  • Owner set to MarbleDice
  • Status changed from confirmed to assigned

[7dab5aa] (SVN r1879) is a temporary hack to address this issue, will attempt a more permanent and graceful solution for 3.1.3.

comment:3 Changed 8 years ago by magnate

  • Keywords id added; identify removed

comment:4 Changed 7 years ago by magnate

  • Description modified (diff)
  • Milestone changed from 3.2.0 to 3.3.0
  • Summary changed from Stat Rings auto-identify if you try to cast identify on them. to Get rid of item_tester_unknown in spells2.c
  • Type changed from bug to change

comment:5 Changed 7 years ago by magnate

  • Type changed from change to task

comment:6 Changed 7 years ago by magnate

  • Milestone changed from 3.3.0 to Future
  • Status changed from assigned to confirmed

Punting in accordance with new milestone policy (that any other milestone is only set once someone is actually working on the ticket).

comment:7 Changed 3 years ago by nckmccnnll

  • Description modified (diff)
  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

I believe this has been fixed for some time

Note: See TracTickets for help on using tickets.