Opened 10 years ago

Closed 9 years ago

#107 closed bug (fixed (in master))

OS X UI bugs

Reported by: pmac Owned by: pmac
Milestone: 3.1.0 Keywords: mac
Cc:

Description (last modified by takkaria)

Some bugs from "Omnipact"

  • (graphics mode) visible monsters aren't rendered in secondary windows
  • cache needs to be invalidated when tilewidth/height/doublewide.
  • overhead view and map view for secondary window broken in graphics mode.

Fixed:

  • Window is creeping down by the height of the titlebar at startup. (Save the actual window region, not the active region) fixed [6358908] (SVN r107)
  • Mouse tracking is off-by-one in y at startup. (side-effect of window creep)
  • Can't change fonts in Term-x windows. fixed [10d7bf3] (SVN r9)
  • Font size and ID are not stored in preferences. fixed [1227c8a] (SVN r105)
  • Graphics settings are not remembered in preferences. fixed [1227c8a] (SVN r105)
  • Font menu should open with current font. fixed [1227c8a] (SVN r105)
  • Quit gracefully when Angband window is not open. fixed [6358908] (SVN r107)

Maybe not a bug:

  • Red window close button for Angband window should always attempt to quit the game.

Change History (18)

comment:1 Changed 10 years ago by pmac

  • Description modified (diff)

comment:2 Changed 10 years ago by pmac

  • Description modified (diff)

comment:3 Changed 10 years ago by pmac

  • Description modified (diff)

comment:4 Changed 10 years ago by pmac

  • Description modified (diff)

comment:5 Changed 10 years ago by pmac

  • Status changed from new to assigned

comment:6 Changed 10 years ago by pmac

  • Description modified (diff)

comment:7 Changed 10 years ago by pmac

  • Description modified (diff)

comment:8 Changed 10 years ago by pmac

  • Description modified (diff)

comment:9 Changed 10 years ago by pmac

  • Description modified (diff)

comment:10 Changed 10 years ago by pmac

  • Description modified (diff)

comment:11 Changed 10 years ago by pmac

  • Description modified (diff)

comment:12 Changed 10 years ago by pmac

  • Description modified (diff)

comment:13 Changed 10 years ago by pmac

  • Description modified (diff)

comment:14 Changed 10 years ago by takkaria

  • component changed from Port-specific to Main game
  • Keywords port added

comment:15 Changed 10 years ago by takkaria

  • Description modified (diff)

comment:16 Changed 10 years ago by takkaria

  • Milestone changed from 3.0.8 to 3.0.9

Moving to 3.0.9

comment:17 Changed 10 years ago by takkaria

  • Keywords mac added; port removed
  • Milestone changed from 3.2.0 to 3.1.0

comment:18 Changed 9 years ago by takkaria

  • Resolution set to fixed
  • Status changed from assigned to closed

Remainder fixed in [0568732] (SVN r976).

Note: See TracTickets for help on using tickets.