Opened 10 years ago

Closed 9 years ago

#1071 closed bug (fixed (in master))

Itemlist leaks info

Reported by: d_m Owned by: noz
Milestone: 3.2.0 Keywords: recall
Cc:

Description

If you have identified a "Robe [2, +0]" on a level, and there's another unidentified robe (that happens to be +0) in the itemlist they will get combined into "Robe [2, +0] (x2)"

When you look at the robe it will still be unidentified. I'm pretty sure the bug is in how the itemlist combines them.

Change History (9)

comment:1 Changed 10 years ago by magnate

  • Keywords recall added
  • Milestone changed from Triage to 3.1.2 beta

comment:2 Changed 9 years ago by magnate

  • Owner set to noz
  • Status changed from new to assigned

comment:3 Changed 9 years ago by noz

This is down to the object_similar() function treating objects in different states of identification as similar, and hence candidates for combining. Should be an easy fix.

comment:4 Changed 9 years ago by takkaria

This isn't a bug, it's intentional behaviour...

comment:5 Changed 9 years ago by noz

  • Status changed from assigned to pending

Fixed by [05331e8] and [8570ae3].

Thanks to d_m for spotting the buy-from-shop exception to the first patch.

comment:6 Changed 9 years ago by magnate

  • Status changed from pending to confirmed

Hmmm. As I said on github, the last commit [7ddfcbd] doesn't actually fix this bug, since it only tests for flavour (which robes don't have) and jewelry status. I think we need an else after the jewelry test which actually does check for ident as noz first proposed.

takkaria - I think we should see how this plays. At the moment there is a bit of a backlash against the game providing too much information. Of course there will be a backlash against things not stacking and ID being painful, but it's probably worth seeing whether this causes a problem. After all, the vast majority of cases we're talking about are +0 wearables, and if the new one doesn't stack people should just get rid of the already-IDd one. I can foresee some arguments from people who obsess over maximising stuff to sell, but I'm quite happy to take those on the chin!

comment:7 Changed 9 years ago by magnate

  • Status changed from confirmed to pending

Ok, complete overkill fix in http://bit.ly/fZhlNg - this provides for the future if we want separate stacking rules for floor, quiver, monster inventory, etc.

comment:8 Changed 9 years ago by magnate

Note to takkaria: the above fix only changes the stacking in the object list, it does not change your preferred behaviour of stacking in inventory. So you can pick up an unIDd dagger(+0,+0) and it will stack with an existing one. It just won't stack them in the object list, so you have to trek across the dungeon to check out the unIDd one.

comment:9 Changed 9 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.