Opened 10 years ago

Closed 6 years ago

#1073 closed change (fixed (in master))

Make Char dumps include more information

Reported by: Tobias Owned by:
Milestone: 3.5.0 Keywords: dump
Cc:

Description (last modified by takkaria)

The object origin string:
So you can show off that ring of speed +7 "dropped by a cave orc on level 20".
It will also help with balancing eventual changes in object generation.
It is more interesting in dumps than the str/dex gain info.

It might also nice to have a "found in a vault" string. I made a patch for this.

The build revision:
also useful.

The message log should also be displayed for living characters.

Attachments (1)

origin_vault.diff (1.2 KB) - added by Tobias 10 years ago.
Marks objects from vaults in the item info

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Tobias

Marks objects from vaults in the item info

comment:1 Changed 10 years ago by magnate

  • Keywords dump added
  • Milestone changed from Triage to 3.1.3

The build revision is #1012. I agree that the object origin text should be shown, but I'm not fussed about the message log: if you're alive, you can take the dump at any point, so the messages are somewhat arbitrary. If you really want to show a bunch of messages, you'll need more than the default number shown in a dump, so you'll need to copy and paste them manually anyway.

comment:2 Changed 9 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:3 Changed 8 years ago by magnate

  • Milestone changed from 4.0 to 3.5.0

These are all underlying or uncontroversial issues, unconnected with the experimental nature of v4 - therefore re-setting to V milestone.

comment:4 Changed 6 years ago by takkaria

  • Description modified (diff)
  • Resolution set to fixed (in master)
  • Status changed from new to closed

Closing as most of these improvements are in by now. Not adding history display.

Note: See TracTickets for help on using tickets.