Opened 10 years ago

Closed 9 years ago

#1092 closed change (fixed (in master))

Look at unique monster colouring again

Reported by: takkaria Owned by: magnate
Milestone: 3.2.0 Keywords: monster display
Cc:

Description

Turning everyone violent has caused some consternation, so 3.1.3 should make use of the new colours instead of just turning everyone violent.

For example, Pete's list of issues:
http://angband.oook.cz/forum/showthread.php?p=29320

Attachments (1)

monster.zip (51.4 KB) - added by Timo Pietilä 9 years ago.
Colors revised to original with changes here and there

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by magnate

  • Keywords display added; graphics removed
  • Status changed from new to confirmed

I'm wondering whether the typo was deliberate. Now that we have more than 16 colours, I think we have to choose between two basic approaches here:

  1. Choose a small set of shades for uniques which are not used for any other monsters (e.g. pinky-purples), but allow some variation (e.g. darker for more powerful).
  1. Have uniques the same basic shade as their monster symbol type, but brighter/darker or otherwise distinct.

Personally I favour 1 because I think the uniqueness is more important to highlight than the monster type, but either could work.

comment:2 Changed 9 years ago by Timo Pietilä

Made a improved version with original color scheme restored, but with uniques using different colors than rest of their kinds. However trac is not accepting my file. I get "The connection was reset" error.

Changed 9 years ago by Timo Pietilä

Colors revised to original with changes here and there

comment:3 Changed 9 years ago by magnate

  • Owner set to magnate
  • Status changed from confirmed to assigned
  • Type changed from bug to change

Timo's changes applied in https://github.com/angband/angband/commit/4de7992f5d176f8a667256bc4c37bac576fbaece

Leaving ticket open due to new requirement for a gameplay option for lovers of purple uniques. Can punt to 3.3 if not ready when everything else is, but I will try to get it done in time for 3.2

comment:4 Changed 9 years ago by Timo

Just to comment that when you originally changed the uniques "purple" you actually used a color that was not at all in original color set. Color codes changed at some point making purple "v" violet and actual purple "P" was then unused. Just getting old monsters.txt searching for monsters with color "v" and changing them all to "P" would restore colors for them to original color, and then searching for uniques and changing them all to "v" would pretty much do the trick without hurting any other monster type.

If you like I could try to do that variation of the color set too (with non-unique monsters changes to more variation like I changed them in that monster.txt)

Version 0, edited 9 years ago by Timo (next)

comment:5 Changed 9 years ago by magnate

Thanks Timo - that would be very helpful.

comment:6 Changed 9 years ago by magnate

  • Status changed from assigned to pending

Option added in http://bit.ly/epH8SC, tested successfully on SDL, GTK and X11 ports. For some reason it is treated as always-on in the GCU port, even when it is explicitly turned off. Leaving that to d_m as he's the master of the GCU code ...

P.S. Timo - many thanks for the offer, but I discovered that 'V' (light violet) was only used for uniques anyway, so it was an obvious candidate for the option.

comment:7 Changed 9 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

Fixed in adf9766c

Note: See TracTickets for help on using tickets.