Opened 10 years ago

Closed 9 years ago

#1093 closed bug (wontfix)

un-ID'd average items stack if there are previously ID'd average items

Reported by: d_m Owned by:
Milestone: 3.2.0 Keywords: id
Cc:

Description

If you have a Dagger (+0, +0) and you pick up another Dagger (that happens to be average) it will immediately stack into 2 Daggers (+0, +0) without having to wield it or do anything else.

Change History (4)

comment:1 Changed 10 years ago by takkaria

That's not a bug. What would your preferred behaviour be?

comment:2 Changed 10 years ago by eddiegrove@…

If there is a discussion going on here, I'd like to repeat my opinion that ID should never affect gameplay. I would not be particularly opposed to daggers never stacking. I've also wondered if items with same tval and sval should always stack, which would lead e.g. to automatic quivers, but a separate one for each ammo type.

comment:3 Changed 10 years ago by magnate

  • Keywords id added
  • Milestone changed from Triage to 3.1.3

I tend to agree with takk that this is not a bug, but it's not my ticket to close.

comment:4 Changed 9 years ago by d_m

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.