Opened 9 years ago

Closed 8 years ago

#1101 closed task (fixed (in master))

Clean up and document savefiles

Reported by: MarbleDice Owned by: MarbleDice
Milestone: 3.3.0 Keywords: loadsave
Cc:

Description

Get rid of save-old.c and load-old.c, document current save file versioning practices, and possibly add support for loading 3.1.1 save files.

Change History (4)

comment:1 Changed 9 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:2 Changed 9 years ago by magnate

  • Keywords loadsave added; cleanup doc removed
  • Milestone changed from 4.0 to 3.3.0

Some changes were made to savefiles recently: not sure if this is now a wontfix.

comment:3 Changed 8 years ago by takkaria

  • Status changed from new to pending

save-old and load-old have been gone a while, I've been doing some cleanup over the past days, and documentation is now in staging as of rev [b8e54e5].

comment:4 Changed 8 years ago by takkaria

  • Resolution set to fixed
  • Status changed from pending to closed

in master now, as of [203f442ba8ed]

Note: See TracTickets for help on using tickets.