Opened 9 years ago

Closed 9 years ago

#1158 closed bug (worksforme)

Message bug: Bad count when dropping from stacks?

Reported by: Nameless Owned by:
Milestone: 3.2.0 Keywords: display
Cc:

Description

Version:

Downloadable Beta (3.1.2v2)

Description:

I noticed when dropping a spellbook that is in a stack in my inventory into my home that the message provided by Angband reports I have dropped the whole stack, and [I]not the number I have actually droppedI. This doesn't create new items or incorrectly handle inventory, but it does incorrectly report the player's actions.

Replication Example:

  1. I have 3 Books of Magic Spells [Sorcery and Evocation] in my inventory.
  2. I drop one.
  3. The message reported is "You drop 3 Books of Magic Spells [Sorcery and Evocation]".
  4. I now have 2 Books of Magic Spells [Sorcery and Evocation] in my inventory, and one laying below me.

Additional Information:

Further testing shows this also occurs with potions and ammunition, so I suspect it's a general issue with the message and not specific to an item type.

Change History (3)

comment:1 Changed 9 years ago by magnate

  • Keywords display added; message, inventory removed
  • Milestone changed from Future to 3.1.3

I cannot replicate this ([8e2d5c7] (SVN r1978), linux). All drop messages are correct in the dungeon, and no message is displayed when dropping items in my home. Leaving open until 3.1.3 in case anyone else can replicate it.

comment:2 Changed 9 years ago by magnate

  • Status changed from new to pending

Still cannot reproduce: almost certain this is a worksforme. Setting to pending until someone else can corroborate.

comment:3 Changed 9 years ago by magnate

  • Resolution set to worksforme
  • Status changed from pending to closed

Considered no longer extant as of http://bit.ly/gQGEo9

Note: See TracTickets for help on using tickets.