Opened 9 years ago

Closed 8 years ago

#1174 closed bug (fixed (in master))

Targeting anomalies with x7 launchers

Reported by: magnate Owned by:
Milestone: 3.2.0 Keywords: combat
Cc:

Description

http://angband.oook.cz/forum/showthread.php?t=3474

Of course, we could just inhibit x7 launchers. But personally I favour allowing targeting to 20 squares rather than 18.

Change History (7)

comment:1 follow-up: Changed 8 years ago by magnate

  • Status changed from new to pending

Fixed in http://bit.ly/hWkqe2 - MAX_RANGE set to 20.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 8 years ago by Timo

Replying to magnate:

Fixed in http://bit.ly/hWkqe2 - MAX_RANGE set to 20.

That's dangerous fix. If spells have max range of 20 that means that as soon as *you* step on sight of some breather it can act immediately toasting you.

Fix needs to separate targeting and spellcast ranges, which this doesn't. WAY better is to leave old behavior which only affected to targeting, not spell ranges. It might be annoying, but it is safe until targeting actually works separately from spell ranges.

comment:3 Changed 8 years ago by Timo

  • Status changed from pending to confirmed

comment:4 in reply to: ↑ 2 ; follow-up: Changed 8 years ago by magnate

Replying to Timo:

That's dangerous fix. If spells have max range of 20 that means that as soon as *you* step on sight of some breather it can act immediately toasting you.

Well, I might have imagined it, but some people have been complaining that the game is too easy now, and needs to be made more challenging .... ;-)

Fix needs to separate targeting and spellcast ranges, which this doesn't. WAY better is to leave old behavior which only affected to targeting, not spell ranges. It might be annoying, but it is safe until targeting actually works separately from spell ranges.

If spells having max range of 20 really does make the game too hard, this change shouldn't be all that difficult - we could simply use "MAX_RANGE - N" for monster spells. Setting N to 2 would re-create the old behaviour for monsters without preventing us fixing this bug.

But if takkaria agrees, I would prefer to playtest the staged fix first to see whether further adjustment is necessary. It's been a long time since anything made the game more challenging, and detection is much more plentiful and effective than it was back in the good old days ...

comment:5 in reply to: ↑ 4 ; follow-up: Changed 8 years ago by Timo

Replying to magnate:

Replying to Timo:

That's dangerous fix. If spells have max range of 20 that means that as soon as *you* step on sight of some breather it can act immediately toasting you.

Well, I might have imagined it, but some people have been complaining that the game is too easy now, and needs to be made more challenging .... ;-)

Fix needs to separate targeting and spellcast ranges, which this doesn't. WAY better is to leave old behavior which only affected to targeting, not spell ranges. It might be annoying, but it is safe until targeting actually works separately from spell ranges.

If spells having max range of 20 really does make the game too hard, this change shouldn't be all that difficult - we could simply use "MAX_RANGE - N" for monster spells. Setting N to 2 would re-create the old behaviour for monsters without preventing us fixing this bug.

But if takkaria agrees, I would prefer to playtest the staged fix first to see whether further adjustment is necessary. It's been a long time since anything made the game more challenging, and detection is much more plentiful and effective than it was back in the good old days ...

If you test, play warrior and play fast in instant-death territory (about 2500'-3000'). Give yourself ESP and one rod of detection, don't accept more of those rods. Also you need to play long time with around 400-500HP to test it, otherwise you don't get the idea of how dangerous that is.

IMO this is not making game more challenging, this is introducing instant death-scenario.

Note that you *can* target and shoot things outside of "targeting range", it just require manual targeting beyond targeting mode targeting.

What needs to be fixed is targeting mode.

I think the right solution would be using new function to determine if target is projectable in target.c target_able. Maybe duplicate the function project_able (in cave.c) with one difference to set MAX_SIGHT instead of MAX_RANGE and use that instead of project_able (target_able in target.c uses project_able to determine if target is actually targetable. At least that is how I understood that part of the code)

comment:6 in reply to: ↑ 5 Changed 8 years ago by Timo

One additional comment. Having spellrange to be same as visual range makes luring things that have shorter than visual range detection range to follow you much harder. There are not many of those things, but they exist.

comment:7 Changed 8 years ago by magnate

  • Resolution set to fixed
  • Status changed from confirmed to closed

Committed to master in http://bit.ly/gQGEo9. This ticket is closed because this bug is actually fixed: there are no more anomalies with x7 launchers. But a new ticket will be necessary if we need to separate MAX_SIGHT from MAX_RANGE as Timo suggests. I'm sure it won't be long before the players of nightlies let us know if it's a problem ...

Note: See TracTickets for help on using tickets.