Opened 10 years ago

Closed 4 years ago

#12 closed change (fixed (in master))

Distribute helpfiles as HTML, PDF

Reported by: takkaria Owned by: myshkin
Milestone: 3.5.0 Keywords: help
Cc:

Description (last modified by takkaria)

This is part of the bug #11, changing the help system.

Wiki version: http://ajps.mine.nu/angband/wiki/UserManual

ajps can probably fairly easily write a nice extrator which you run on the wikitext to produce good HTML. Apply stylesheet and distribute with the game.

Also, use Prince to generate a nice PDF manual from the HTML.

Change History (15)

comment:1 Changed 10 years ago by takkaria

  • Milestone changed from 3.0.8 to 3.0.9

comment:2 Changed 10 years ago by takkaria

  • Description modified (diff)
  • Summary changed from Work Leon Marrick's helpfiles into HTML format to Distribute helpfiles as HTML, PDF

comment:3 Changed 10 years ago by takkaria

  • Description modified (diff)

comment:4 Changed 10 years ago by takkaria

  • Type changed from feature to task

comment:5 Changed 10 years ago by takkaria

  • Keywords help added

comment:6 Changed 10 years ago by takkaria

  • component changed from Interface to Main game

comment:7 Changed 9 years ago by takkaria

  • Milestone changed from 3.2.0 to 3.1.2 beta

comment:8 Changed 7 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:9 Changed 7 years ago by magnate

  • Type changed from task to change

comment:11 Changed 6 years ago by magnate

  • Milestone changed from 4.0 to 3.3.0
  • Status changed from new to confirmed

comment:12 Changed 6 years ago by myshkin

  • Owner set to myshkin
  • Status changed from confirmed to assigned

comment:13 Changed 6 years ago by magnate

  • Resolution set to fixed
  • Status changed from assigned to closed

Included in 3.3.0 with a "make manual" build target which builds the PDF from LaTeX. Although the build system doesn't currently build HTML help, it can do eventually, and there's already a comprehensive online manual at http://rephial.org/wiki/UserManual.

comment:14 Changed 6 years ago by magnate

  • Milestone changed from 3.3.0 to Future
  • Resolution fixed deleted
  • Status changed from closed to reopened

On second thoughts, I was too hasty. This really needs takkaria's vew on the shipping of HTML. But many thanks to myshkin for getting the PDF building properly, and to qwerty for the LaTeX.

comment:15 Changed 4 years ago by takkaria

  • Description modified (diff)
  • Milestone changed from Future to 3.5.0
  • Resolution set to fixed (in master)
  • Status changed from reopened to closed

Fixed in ed9a898.

Note: See TracTickets for help on using tickets.