Opened 8 years ago

Closed 8 years ago

#1218 closed change (fixed (in master))

Remove more options

Reported by: takkaria Owned by: takkaria
Milestone: 3.3.0 Keywords: options
Cc:

Description

first impressions:

interface:

  • squelch_worthless (off)
  • hide_squelchable (on) — introduce an 'undo squelch' command that undoes the last change
  • show_lists (on)

display:

  • highlight_player (off)
  • show_piles (on)
  • show_labels (on)
  • view_bright_light (on)
  • view_granite_light (on)
  • view_special_light (on)
  • view_perma_grids (on)
  • view_torch_grids (on)

warning and disturb:

  • quick_messages (on)
  • ring_bell (off)
  • flush_failure (on)

birth:

  • maximise (on)

Change History (6)

comment:1 Changed 8 years ago by magnate

I agree with all those except squelch_worthless, but I can always do that in my own pref file. According to #1061, hide_squelchable should be a toggle command rather than an option ...

comment:2 Changed 8 years ago by magnate

  • Keywords options added
  • Status changed from new to confirmed

IMO easy_open and easy_alter should also be removed (and set to ON). There should be a specific command to deliberately walk into a trap, e.g. shift-w (which, like shift-t, would prompt for a direction).

comment:3 Changed 8 years ago by takkaria

most of these in staging now (as of [frfb83d9a])-- missing are:

  • maximise
  • easy_open (which I think should remain an option for now, since I find it really frustrating)
  • flush_failure

comment:4 Changed 8 years ago by takkaria

flush_maximise is now in staging too

comment:5 Changed 8 years ago by magnate

I'd like to plead for keeping maximise mode as an option. It costs nothing to keep the option and it makes for quite a different gameplay experience - like many of the other birth options.

That would mean this ticket can be closed ...

comment:6 Changed 8 years ago by takkaria

  • Resolution set to fixed
  • Status changed from confirmed to closed

OK, I buy that maximise shouldn't be a simple "remove option" thing, new ticket filed as #1297. Closing as fixed.

Note: See TracTickets for help on using tickets.