Opened 8 years ago

Closed 8 years ago

#1219 closed bug (fixed (in master))

Preference loading fails

Reported by: Taha Owned by: takkaria
Milestone: 3.2.0 Keywords: prefs macros
Cc:

Description

Since at least the Nov 19th nightly, option and macro loading have given an error. With a fresh character, choosing save options, use the default file, and then hit load for the same file gets a "Failed to load 'Character.prf'!" Macro loading gives the same error.

On an existing character, where I manually modified the macros (to get around some other current bugs) and reloaded, it does appear to be reading the macros in correctly, but gives the same error.

I thought it might have been an error with my pre-existing character, but the game should be able to create and then read back its own unmodified preference save on a fresh character.

Change History (5)

comment:1 Changed 8 years ago by magnate

  • Keywords prefs added; prefs, removed
  • Milestone changed from Triage to 3.2.0
  • Status changed from new to confirmed

There are definitely some bugs with pref file loading but I can get it to work by saving a macro pref file and restarting and manually loading it in (albeit with parsing errors). I think the bug may be connected to the default naming but I'm not sure.

Up to takk whether to fix this before reimplementing macros and prefs though ... I will tag as 3.2 for now ...

comment:2 Changed 8 years ago by takkaria

  • Owner set to takkaria
  • Status changed from confirmed to assigned

Taha, I'll check this out using the pref file you sent in.

comment:3 Changed 8 years ago by Timo

I'm seeing this too. Maybe it should say which line of the pref-file causes the error because it does seem to load it, but still throws that error in screen (it does seem to give that error on all kinds of pref-files, even ones just created by the game). Maybe error is actually in error message itself. Instead of giving "successfully loaded pref file" it gives that "failed to load pref file".

comment:4 Changed 8 years ago by takkaria

  • Status changed from assigned to pending

fixed in [ab14f7f], http://bit.ly/f1pzSx

comment:5 Changed 8 years ago by takkaria

  • Resolution set to fixed
  • Status changed from pending to closed

now in master

Note: See TracTickets for help on using tickets.