Opened 8 years ago

Closed 5 years ago

#1239 closed bug (fixed (in master))

Nomad tiles + SDL = problems

Reported by: d_m Owned by:
Milestone: 3.5.0 Keywords: sdl graphics
Cc:

Description (last modified by takkaria)

For some reason, when using Nomad's tiles (8x16) in SDL, the floor tiles don't change color based on which tiles are visible. You can compare this to the Adam Bolt tiles (16x16) to see what I mean.

Also, it seems like transparency isn't working with SDL either, but I think that's less of an issue.

Change History (6)

comment:1 Changed 8 years ago by magnate

  • Keywords graphics added; tiles nomad removed
  • Milestone changed from Triage to 3.3.0
  • Status changed from new to confirmed

This bug also exists with the "old" (8x8) tiles. Presumably it is intrinsic to the tileset? Or do those tilesets have different coloured floor tiles for different lighting levels?

comment:2 Changed 8 years ago by d_m

Also, I think the Nomad tiles are displaying at 16x16 not 8x16 like they are supposed to.

Sigh.

comment:3 Changed 8 years ago by d_m

The floor visibility shading still doesn't work, but I did fix the transparency issue and the tiles are the correct dimension.

So I'm leaving this open but it really is just about the floor tile/visibility issue.

comment:4 Changed 7 years ago by magnate

  • Milestone changed from 3.3.0 to Future

Punting to Future because of lack of owner and imminent release of 3.3.0

comment:5 Changed 6 years ago by takkaria

  • Milestone changed from Future to 3.5.0

Assigning still-open bugs from Future to 3.5 for fixing.

comment:6 Changed 5 years ago by takkaria

  • Description modified (diff)
  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.