Opened 7 years ago

Closed 7 years ago

#1265 closed bug (fixed (in master))

Slow game and map/overhead term window

Reported by: Timo Owned by:
Milestone: 3.3.0 Keywords: display
Cc:

Description

Might be related, or two separate cases.

  1. Game is slow for some reason when you use "overhead" term window and there is unseen monster activity nearby. That's noticeable at a degree that you know there is a monster nearby by the fact that game slows down at very early levels, not so much deeper in dungeon when there is always lots of monsters around.
  1. Entire "overhead" -term window flickers when there is a visible monster with flicker on.
  1. Stretched "Map" term window doesn't get properly updated, it leaves behind traces of areas that should not be there. To reproduce you need to "Look around" with look command, when you change sector in look-command same happens in map term window, and also when char passes sector border so that map moves to next position same happens.

1 and 2 might be related in that overhead view probably uses a lot of CPU to track monsters (even unseen ones) and refresh screen, and that refresh probably is linked to map view leaving behind traces of areas might be same thing, just different way to show it.

Change History (4)

comment:1 Changed 7 years ago by magnate

  • Keywords display added

If 1 only happens when flicker is on, I'm certain it is the same problem as 2.

3 I suspect has been around for aeons and you're the first person to report it ...

comment:2 Changed 7 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Eddie confirms that 1 happens without flicker, unfortunately. I cannot reproduce, so might be specific to Windows.

Postponing to 3.3 per IRC.

comment:3 Changed 7 years ago by magnate

  • Status changed from new to confirmed

From jens on oook:

"- No matter if the option is on/off, show it in original color on the overhead map. Would remove the need to redraw the overhead map, and would help with the problem that Timo (and I) have with the overhead map flickering and slowing down the game. If the option is on, the overhead map flickers every time the monsters switch color, if the option is off it's the same, i.e. the overhead map flickers every turn, so running is slow, and resting more so."

comment:4 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from confirmed to closed

Not reported by playtesters of 3.3.0 RCs, so believed fixed in or before [rfd51c57].

Note: See TracTickets for help on using tickets.