Opened 8 years ago

Closed 8 years ago

#1281 closed bug (fixed (in master))

Launch angband results in "angband: Cannot open 'hints.txt'"

Reported by: SaThaRiel Owned by:
Milestone: 3.2.0 Keywords: cleanup
Cc:

Description

Using commit 4d13461866af59365ed922cae3a57c5b6e328364
Already removed and reinstalled angband. Also moved savefile and whole .angband/Angband folder away. Angband wont start.

Compiled with

  CFLAGS=""
  ./autogen.sh
  ./configure \
    --prefix=/usr \
    --bindir=/usr/bin/ \
    --sysconfdir=/usr/share/angband \
    --with-configpath=/usr/share/angband \
    --with-libpath=/usr/share/angband \
    --enable-gtk \
    --enable-sdl \
	--enable-sdl-mixer || return 1
  make clean
  make || return 1

Tried gtk and gcu modes. No change.
With gcu the start window opens for a short time but closes immediatly.

Change History (3)

comment:1 Changed 8 years ago by SaThaRiel

Copying hints.txt from src/lib/edit to the destination edit dir solves the problem. Looks like a Makefile problem.

comment:2 Changed 8 years ago by takkaria

Try now with 934ca1d49ab5522a37b1c23f5006ce1a07f95b1a (latest angband/angband master).

comment:3 Changed 8 years ago by magnate

  • Keywords cleanup added
  • Milestone changed from Triage to 3.2.0
  • Resolution set to fixed
  • Status changed from new to closed

Confirmed fixed by OP

Note: See TracTickets for help on using tickets.