Opened 8 years ago

Closed 5 years ago

#1293 closed bug (fixed (in master))

Inconsistent behaviour about dropping squelched items

Reported by: magnate Owned by:
Milestone: 3.5.0 Keywords: squelch
Cc:

Description (last modified by takkaria)

Press 'k' to ignore an item in your pack. You do not drop it immediately unless 'K' is on.

Drop it manually and move away from it. Toggle 'K' a few times to watch it appear and disappear. When it's visible, go and pick it up again. Save and exit. Reload.

The first thing to happen is You drop a foo {squelch}.

This is inconsistent: either you should drop squelched stuff the moment you squelch it, or you should keep it until 'K' is toggled on. Since you can pick up visible squelched items, I suggest the latter.

Change History (7)

comment:1 Changed 8 years ago by magnate

  • Description modified (diff)
  • Summary changed from Savefile does not remember status of 'K' toggle to Inconsistent behaviour about dropping squelched items

comment:2 Changed 8 years ago by takkaria

The reason this happens is because the K-state isn't saved in the savefile.

comment:3 Changed 8 years ago by takkaria

  • Milestone changed from Triage to 3.3.0

comment:4 Changed 8 years ago by magnate

  • Status changed from new to confirmed

comment:5 Changed 8 years ago by magnate

  • Milestone changed from 3.3.0 to Future

Not addressed in 3.3.0 - re-setting to Future as unowned

comment:6 Changed 6 years ago by takkaria

  • Milestone changed from Future to 3.5.0

Assigning still-open bugs from Future to 3.5 for fixing.

comment:7 Changed 5 years ago by takkaria

  • Description modified (diff)
  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.