Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1294 closed bug (duplicate)

Version 3.2 crashes immediately upon startup (Intel Mac, OS X 10.5.8)

Reported by: griefandtrepidation Owned by:
Milestone: 3.3.0 Keywords: mac
Cc:

Description

Since updating to 3.2, Angband invariably crashes upon startup. I have extracted from the flaming wreckage a crash report:

Process:         angband [5625]
Path:            /Users/set/Roguelikes/Angband/Angband.app/Contents/MacOS/angband
Identifier:      net.thangorodrim.Angband
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [120]

Interval Since Last Report:          28006451 sec
Crashes Since Last Report:           77
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   4

Date/Time:       2010-12-28 18:57:31.872 -0500
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  A38E8CB8-5205-4751-9DCC-37E227FC03BA

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  unknown required load command 0x80000022

If any additional information is necessary, I shall gladly supply it. I am uncertain whether this issue is related to ticket #1282, but the crash report seemed sufficiently different to justify filing a separate ticket for this error.

Change History (6)

comment:1 Changed 9 years ago by griefandtrepidation

comment:2 Changed 9 years ago by myshkin

Could you show the results of running "make -f Makefile.osx clean all"? Your log doesn't show the building of the individual object files, which seem to be of some foreign architecture. From where did you get your source tree?

comment:3 Changed 9 years ago by darint

Yes, the 3.2.0 source distribution from rephial seems to have *.o files from some previous attempt to compile. Remove the *.o files and you should stop getting those errors.

comment:4 Changed 9 years ago by griefandtrepidation

darint is correct. I obtained the source from rephial.org, and removing the various *.o files now allows it to compile properly.

comment:5 Changed 9 years ago by takkaria

  • Resolution set to duplicate
  • Status changed from new to closed

This turns out to be a dupe of #1299. It's been fixed now.

comment:6 Changed 9 years ago by myshkin

  • Milestone changed from Triage to 3.3.0
Note: See TracTickets for help on using tickets.