Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#1318 closed bug (fixed (in master))

Quality squelching settings not saved when game is exited

Reported by: pampl Owned by:
Milestone: 3.3.0 Keywords: squelch loadsave windows
Cc:

Description

On exiting and restarting the game, all the quality squelch settings are reset back to no squelching. Even loading the pref file doesn't restore quality squelch settings. Flavor squelching is remembered correctly, though.

Change History (10)

comment:1 Changed 8 years ago by magnate

  • Keywords squelch loadsave added; squelch, quality removed

I cannot reproduce this. My quality squelch settings are preserved on save/load.

comment:2 Changed 8 years ago by magnate

  • Resolution set to worksforme
  • Status changed from new to closed

Myshkin can't reproduce it either - closing as a local problem. Please attach a savefile if you want to re-open this.

comment:3 Changed 8 years ago by GabeCunningham

  • Milestone changed from Triage to 3.3.0
  • Resolution worksforme deleted
  • Status changed from closed to reopened

My quality squelch settings aren't saved either, and fizzix reports the same problem. I'm playing the nightlies on Windows 7. Reopening.

comment:4 Changed 8 years ago by ChodTheWacko

The Original bug doesn't say, but squelching is part of the saved character.
It should not be in the pref file, nor generic settings.

The main reason for this is that a high level character will be squelching nearly everything (except say artifacts), but when you die and restart, you want the new character to be squelching nothing.

comment:5 Changed 8 years ago by fizzix

The problem appears to be windows only. Characters do not retain quality squelch settings on save/reload in Windows.

comment:6 Changed 8 years ago by magnate

  • Keywords windows added

comment:7 Changed 7 years ago by magnate

According to #784, this was a deliberate change in [r635e36c]. But something is obviously awry with the Windows pref handling, or something.

comment:8 Changed 7 years ago by magnate

comment:9 Changed 7 years ago by magnate

  • Status changed from reopened to pending

[r72b3e87]

comment:10 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

[rfd51c57]

Note: See TracTickets for help on using tickets.