Opened 9 years ago

Closed 9 years ago

#1337 closed bug (fixed (in master))

Crash in nightlies on firing while confused

Reported by: pampl Owned by:
Milestone: 3.3.0 Keywords: crash, firing, confusion
Cc:

Description

Not sure what exactly caused it, but it happened when a DE lord was running away and confused me. I wasn't paying attention so I didn't notice I was confused and tried to gun him down with a pebble of acid from my quiver. I got a message that the pebble of acid hit a player (offscreen) and corroded them, then the game crashed.

Change History (3)

comment:1 Changed 9 years ago by GabeCunningham

I had something similar happen earlier today when firing plain arrows at Mughash. Most of them worked fine, but suddenly the game crashed.

comment:2 Changed 9 years ago by GabeCunningham

  • Milestone changed from Triage to 3.3.0
  • Status changed from new to confirmed

Okay, I think my earlier problem was unrelated. The problem here seems to be that if you target yourself and fire, it's possible to hit yourself and cause an assertion to fail.

comment:3 Changed 9 years ago by GabeCunningham

  • Resolution set to fixed
  • Status changed from confirmed to closed

I think this is fixed as of [3a7ac1b]. Please reopen if you have this problem again with the latest nightlies.

Note: See TracTickets for help on using tickets.