Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#1341 closed change (fixed (in master))

Remove off-weapon brands and tone down down +dmg

Reported by: takkaria Owned by:
Milestone: 3.3.0 Keywords: items
Cc:

Description


Change History (3)

comment:1 Changed 8 years ago by magnate

I would really like to argue against the in principle removal of off-weapon brands. In the standard artifact set they appear only on five items: the four elemental rings, and Paurnimmen. The former need to be worn at the expense of =speed, =dam and =power, and the latter has no FA, +damage, +stats or high resists, all of which are available on artifact or ego gloves.

I also think that the problem has been oversimplified. The problem is that damage output is now too high relative to monster hp, but I think the o-w brands are a smaller part of the problem than people think. Please take randarts out of the equation when thinking about this, as they are currently overpowered and will be rewritten. So we're back to Pain + branded ring as the most broken combination.

I think we should tackle the problem in a logical order:

  1. Make high-end egos and artifacts less likely to be generated.
  2. Reduce the off-weapon +dam of standard artifacts and egos.
  3. Make off-weapon brands add half the extra damage of on-weapon brands.

We need also to look at this in parallel with spell and device damage, evasion/absorption changes, and toning down overpowered non-damage items (ego DSMs).

comment:2 Changed 7 years ago by magnate

  • Keywords items added; gameplay removed
  • Status changed from new to pending

Brands went some time ago; off-weapon damage and speed are addressed in [rff35e8d].

comment:3 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In master as of [r72e6029], Sun 22 May 2011.

Note: See TracTickets for help on using tickets.