Opened 8 years ago

Closed 8 years ago

#1346 closed bug (fixed (in master))

Pseudo-id / id-by-use issues

Reported by: GabeCunningham Owned by:
Milestone: 3.3.0 Keywords: id
Cc:

Description

  1. If you have a dagger (+0, +0) (known), and you pick up a dagger that is average but not id'd yet, the two stack and the dagger is id'd.
  1. Once you've wielded a weapon and learned its plusses, it seems you never sense whether it is "average", "good", etc. Instead, its flags are tracked as if it is excellent.
  1. Suppose you start with a wand of confuse monster, and the monster you aim it at resists. Then even if you later successfully use it to confuse a monster, it is still not id'd by use.

Change History (5)

comment:1 Changed 8 years ago by takkaria

1 is not an issue, it's intentional.

comment:2 Changed 8 years ago by eddiegrove

For (2), when the {tried} or {worn} goes away that means you have full ID. When you inspect, do you get a message like "You do not know the full extent of this item's powers"? If not, it has full ID status.

I've always succeeded with (3). You'll need to attach a savefile for us to have any hope of tracking down whatever peculiarity got you.

comment:3 Changed 8 years ago by GabeCunningham

Okay, after testing (2) again, it turns out that I was just pseudo-ing much slower than I expected, and the {worn} does eventually go away.

I've consistently had (3) happen, though I think it worked fine in an earlier version. I tried to attach a savefile without any luck. I was able to easily reproduce it using debug commands.

comment:4 Changed 8 years ago by GabeCunningham

  • Milestone changed from Triage to 3.3.0
  • Status changed from new to pending

Fixed in staging as of [3c4382f].

comment:5 Changed 8 years ago by GabeCunningham

  • Resolution set to fixed
  • Status changed from pending to closed

Now in master.

Note: See TracTickets for help on using tickets.