Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1364 closed bug (fixed (in master))

A couple object.txt typos

Reported by: Zaxx Owned by:
Milestone: 3.3.0 Keywords:
Cc:

Description

  • the description of the Cutlass says "the sabre is a slashing sword" instead of "cutlass"
  • all allocation values for common armor parts have been changed to 20, except for Leather Boots (still 110)

Rings of Strength have allocation from 10 to 100 (all other stat rings are 30 to 100). Is that intended?

Rods of Curing have a mimimum allocation level of 10 and a base level of 65, which will generate "superb" feelings each time this crappy item is generated at low/mid level. Intended again?

Change History (4)

comment:1 Changed 7 years ago by Zaxx

Looking at the source code, it's even worse for Rods of Curing. For example, at dlvl 30, a Rod of Curing will be considered "out-of-depth" (object level 65, depth 30). In this case, a rating boost of (min alloc - depth) will be applied, which will be -20!

How to fix this issue (which probably arises for all items with object level > min alloc)... I don't know. Apply the same threshold for out-of-depth check and rating boost? Align object level and min alloc for objects with object level > min alloc?

comment:2 Changed 7 years ago by d_m

  • Status changed from new to pending

There are four issues here:

  1. Fixed in staging. Thanks for catching this!
  2. This was already fixed
  3. This was already fixed
  4. Working as intended for now... it's maybe worth removing or reconsidering rods of curing/restoration but that is more of a new feature and less of a bug.

Feel free to open an enhancement request just dealing with rods of curing, or other suggestions.

I'm marking this issue pending and when staging -> master will close it.

comment:3 Changed 7 years ago by d_m

  • Resolution set to fixed
  • Status changed from pending to closed

comment:4 Changed 7 years ago by myshkin

  • Milestone changed from Triage to 3.3.0
Note: See TracTickets for help on using tickets.