Opened 9 years ago

Closed 8 years ago

#1368 closed bug (worksforme)

wizmode: cope with negative values when tweaking objects

Reported by: magnate Owned by: GabeCunningham
Milestone: Triage Keywords: wizmode
Cc:

Description (last modified by magnate)

Entering a negative +ac value for a ring of protection causes a crash with the output "software bug". I haven't tested, but this may well apply to entering other negative values during tweaking various object types.

Ideally the tweaking should accept any negative values. Where this is impossible, I suggest that any negative value is re-set to 0, rather than complicating the tweaking interface.

Change History (4)

comment:1 Changed 9 years ago by magnate

  • Status changed from new to confirmed

comment:2 Changed 8 years ago by GabeCunningham

  • Owner set to GabeCunningham
  • Status changed from confirmed to assigned

comment:3 Changed 8 years ago by GabeCunningham

I can't reproduce this. Setting a negative AC seems to work fine for me. Does this crash for anyone else?

comment:4 Changed 8 years ago by magnate

  • Description modified (diff)
  • Milestone changed from 3.4.0 to Triage
  • Resolution set to worksforme
  • Status changed from assigned to closed

Confirmed that this crash no longer happens in either V 3.4-dev or v4. Thanks for checking Gabe!

Note: See TracTickets for help on using tickets.