Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1369 closed change (fixed (in master))

Rebalance ego DSMs

Reported by: magnate Owned by: magnate
Milestone: 3.3.0 Keywords: items
Cc:

Description

I think it is generally agreed that ego DSMs, while interesting, are unbalanced as initially implemented by me. Currently available are:

Resistance, rarity 2
Permanence, rarity 4
Dwarven, rarity 4 (up from 2 initially)
Stealth, rarity 6
Speed, rarity 24

The first two are not available on the bottom six DSMs (black, white, red, blue, green, multihued). If rarities are strictly comparable then Stealth should be three times rarer than Resistance on the upper DSMs, but observation does not seem to bear this out and stats have not yet been run (time for me to get to grips with fizzix's excellent work). Speed in particular seems too common, as does Permanence.

The problem is deeper than simply tweaking the numbers though. AFAICT, there is no way for an ego to "fall back" to a non-ego item if all the rarity checks fail (in fact I'm not even sure that artifacts do this any more, which might explain the increase in artifacts since 3.1). So having too few ego types available is a Bad Thing, as they will all get more common.

Fundamentally I'd like to amend ego item generation so that DSM egos can sometimes fail to be generated, leaving standard "good" DSM. This would fix an observed problem where too high a proportion of DSMs are egos.

Beyond that, it would be good to add *more* ego types, so that the incidence of any one type decreases further. Elvenkind is an obvious one (people seem to think it's already available, but it isn't). Other suggestions welcome.

Obviously Permanence needs to be a lot rarer if it is to remain at all, on a par with speed. Speed needs to be toned down to MB(5) rather than 1d10. Both these require separate entries in ego_item.txt to avoid messing with robes and boots.

I am a little out of touch, and posting this so that anyone else working on object generation can comment. There was talk of rewriting ego generation completely, so I'm interested if anyone is planning that for 3.3.

Change History (5)

comment:1 Changed 8 years ago by magnate

  • Status changed from new to assigned

comment:2 Changed 8 years ago by magnate

jens has come up with a potential quick fix for this: http://angband.oook.cz/forum/showthread.php?p=53581#post53581. If takkaria agrees, I would propose the following for 3.3:

  • remove permanence
  • change speed to rarity 100 and pval M5 only
  • increase rarities: resistance and stealth to 10, dwarven to 20
  • add Elvenkind with rarity 33
  • add Craftsmanship (+d6 AC, no to-hit malus) with rarity 2

This should produce 50 of Craftsmanship for every 10 of resistance, 10 of stealth, 5 Dwarven, 3 of Elvenkind and 1 of speed. I could run some stats to test for this.

comment:3 Changed 8 years ago by takkaria

let's give it a go.

comment:4 Changed 8 years ago by magnate

  • Status changed from assigned to pending

Ok, done in [rea1bace]. Let's see how that goes.

comment:5 Changed 8 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In master as of [r022d04e]

Note: See TracTickets for help on using tickets.