Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#1370 closed bug (fixed (in master))

Pricing overflow

Reported by: magnate Owned by: magnate
Milestone: 3.3.0 Keywords: stores
Cc:

Description (last modified by magnate)

This is a direct consequence of me underestimating the time lag between adding multiple pvals (26 Dec) and rewriting obj-power (tbc). Needs a quick fix to keep nightlies playable.

This results in certain items (buckland slings, lothlorien bows) occasionally being worth 1gp, if they have a +4 pval for Dex which is mis-read as +4 shots.

Change History (4)

comment:1 Changed 9 years ago by magnate

  • Description modified (diff)
  • Status changed from new to confirmed

comment:2 Changed 9 years ago by magnate

  • Owner set to magnate
  • Status changed from confirmed to assigned

A quick look has revealed that this fix is actually almost as much hassle as the obj-power rewrite (#1003 et al.). Now that #803 is done, there's no need to put that off any longer.

Note to self: there are only two remaining calls to object_pval_is_visible outside obj-power.c - the one in squelch.c needs correcting to this_pval_ and the one in obj-desc.c can be replaced with a loop. The function can then be removed, since it's superseded by object_this_pval_is_visible.

comment:3 Changed 8 years ago by magnate

  • Status changed from assigned to pending

In staging as of [rb4a8644]

comment:4 Changed 8 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In nightlies as of 17th April [r2d17857]

Note: See TracTickets for help on using tickets.