Opened 8 years ago

Closed 7 years ago

Last modified 8 years ago

#1373 closed bug (fixed (in master))

Special artifacts appearing in squelch menus?

Reported by: nckmccnnll Owned by: myshkin
Milestone: 3.3.0 Keywords: squelch
Cc:

Description

In the squelch menu, under "Amulets" there is a type listed as
"Amulet". Under "Rings" there is a type listed as "Ring."

http://angband.oook.cz/forum/showpost.php?p=49708&postcount=1

Attachments (1)

diff.txt (1.4 KB) - added by eddiegrove 8 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 8 years ago by magnate

Please attach a savefile - I can't reproduce this in current staging. I see only flavours under both menus. Could it be related to #978 or #1273?

comment:2 follow-up: Changed 8 years ago by nckmccnnll

Dunno - my entire knowledge of it is on oook at the link.

comment:3 in reply to: ↑ 2 Changed 8 years ago by magnate

Replying to nckmccnnll:

Dunno - my entire knowledge of it is on oook at the link.

Ok - need a little more info from the OP then. It could be a regression.

comment:4 Changed 8 years ago by myshkin

I can reproduce this behavior in a brand new savefile on HEAD of staging (commit ebdff52).

comment:5 Changed 8 years ago by magnate

I can confirm that a clean build of ebdff52 on 32-bit Linux, with new savefile, does not produce this behaviour - all squelch menus look normal. How weird is that?

Changed 8 years ago by eddiegrove

comment:6 Changed 8 years ago by eddiegrove

I saw what might be this bug, and fixed it in my own copy some time back. I think the start of the attached diff is what I changed to fix it. Some day I'll transfer everything to a fork with lots of separate commits I hope, but anyone who wants to fix things now might find the answer there.

Last edited 8 years ago by eddiegrove (previous) (diff)

comment:7 Changed 8 years ago by myshkin

  • Milestone changed from Triage to 3.3.0
  • Owner set to myshkin
  • Status changed from new to assigned

Yes, something along the lines of Eddie's patch is the right direction. However, do we want special artifacts to appear in squelch menus after they've been found and identified?

comment:8 follow-up: Changed 8 years ago by eddiegrove

BTW, I believe the reason the bad behavior goes away on a fresh savefile is that the artifact base flavoers are not everseen, so they are excluded for that reason.

comment:9 in reply to: ↑ 8 ; follow-up: Changed 8 years ago by magnate

Replying to eddiegrove:

BTW, I believe the reason the bad behavior goes away on a fresh savefile is that the artifact base flavoers are not everseen, so they are excluded for that reason.

Yes I thought that should be the case, but myshkin said he *could* reproduce it with a brand new savefile. If the squelch menus are using everseen info, I'm pretty sure the solution to this should also fix #1273. Myshkin?

comment:10 in reply to: ↑ 9 ; follow-up: Changed 8 years ago by eddiegrove

Replying to magnate:

Replying to eddiegrove:

BTW, I believe the reason the bad behavior goes away on a fresh savefile is that the artifact base flavoers are not everseen, so they are excluded for that reason.

Yes I thought that should be the case, but myshkin said he *could* reproduce it with a brand new savefile. If the squelch menus are using everseen info, I'm pretty sure the solution to this should also fix #1273. Myshkin?

You make a good point. I missed the implication of myshkin's comment.

Despite the comment in the diff, I got everything fixed to my satisfaction, including not listing mushrooms of turbulence. I had a surprising amount of trouble achieving such a trivial change.

Fixing this doesn't fix #1273, unless the fix [a big step backwards IMO] is to remove everseen flavors and e.g. disallow squelching of ?darkness by that name until aware. I'd prefer the object knowledge menu to be increased from aware flavors to everseen flavors, and an additional yes/no column added for flavored items "seen this game" meaning whether aware.

comment:11 in reply to: ↑ 10 ; follow-ups: Changed 8 years ago by magnate

Replying to eddiegrove:

Despite the comment in the diff, I got everything fixed to my satisfaction, including not listing mushrooms of turbulence. I had a surprising amount of trouble achieving such a trivial change.

I think I'm missing something here - what was the problem with ,turbulence?

Fixing this doesn't fix #1273, unless the fix [a big step backwards IMO] is to remove everseen flavors and e.g. disallow squelching of ?darkness by that name until aware. I'd prefer the object knowledge menu to be increased from aware flavors to everseen flavors, and an additional yes/no column added for flavored items "seen this game" meaning whether aware.

I agree - the knowledge menus are all about metagame knowledge, so they should definitely include everseen info. Instead of having an extra column, how about having the everseen items in grey and the seen-this-game items in white?

This means the only flavours displayed would be for never-seen items - that works for me.

comment:12 in reply to: ↑ 11 Changed 8 years ago by magnate

Replying to magnate:

This means the only flavours displayed would be for never-seen items - that works for me.

Myshkin reminds me that this would prevent squelching of tried-but-not-IDd flavours, which would be bad. So instead we should have name and flavour in separate columns ...?

comment:13 in reply to: ↑ 11 Changed 8 years ago by myshkin

Replying to magnate:

Replying to eddiegrove:

Despite the comment in the diff, I got everything fixed to my satisfaction, including not listing mushrooms of turbulence. I had a surprising amount of trouble achieving such a trivial change.

I think I'm missing something here - what was the problem with ,turbulence?

I assume this is the alloc_prob == 0 case.

Fixing this doesn't fix #1273, unless the fix [a big step backwards IMO] is to remove everseen flavors and e.g. disallow squelching of ?darkness by that name until aware. I'd prefer the object knowledge menu to be increased from aware flavors to everseen flavors, and an additional yes/no column added for flavored items "seen this game" meaning whether aware.

I agree - the knowledge menus are all about metagame knowledge, so they should definitely include everseen info. Instead of having an extra column, how about having the everseen items in grey and the seen-this-game items in white?

This means the only flavours displayed would be for never-seen items - that works for me.

I'm a bit confused. I will try to summarize desired behavior to see if you all agree. I am assuming that squelch and object knowledge menus should display the same information...please speak up if that's not the case.

Names. (i.e. "Strength")

Aware: display in white
Everseen but not aware: display in grey
Never seen: do not display

Flavors. (i.e. "Alexandrite")

Aware: do not display
Not aware: display in white

comment:14 Changed 8 years ago by magnate

I agree, but I'm thinking about the formatting, and in particular about the same item appearing twice in the list (once in grey as an everseen-but-unaware item, and once as an unaware flavour). Perhaps this doesn't actually matter though.

comment:15 Changed 8 years ago by eddiegrove

You need the double entries for unaware flavors for full squelch capability. It is not so important now, but in the old days when e.g. you knew a scroll was trap creation and you could not gain ident via use it was a big deal to me. Now I might use it for potions with no obvious effect when hurt or mushrooms I know are not vigor, but I don't squelch unaware much at all any more.

In my code, assuming everseen on everything, at the start there are exactly as many extra unaware flavors as there are artifacts. I do not display an entry for the unaware version of a mushroom of turbulence. That's my preference, but I am not 100% sure that is right.

Myshkin's solution is elegant, but it may be too elegant. Are we sure that white vs grey will be obvious to all players on all devices in all playing conditions? I used the ugly approach of adding " (unseen)" when constructing names for unaware flavors. That also shows up in names in shops, where the colors already have meanings so white vs grey is not an option. However, the extra chars are probably bad for portable devices. A different approach that might be too subtle is to distinguish via capitalization or something like that. Maybe capitalization + white_vs_grey when available?

comment:16 Changed 8 years ago by eddiegrove

Oh - I know some people want to squelch all mushroom flavors unaware at the start of the game. That might be enough reason to keep the double entries all by itself.

comment:17 Changed 8 years ago by myshkin

On further consideration, I have a new plan.

  • Get rid of the existing squelch menu, and have the squelch item in the options menu launch the object knowledge browser. I'll need to find a place to put quality squelching.
  • Add everseen svals and INSTA_ART svals to the object knowledge browser. (If nothing else, everything needs to be here for autoinscription.)
  • Add an "ID?" column to the knowledge browser to denote whether svals are aware in this game. I would be happy to have a better header than "ID?" without making it too long.

I am not entirely sold on our current use of white vs. grey for aware vs. unaware, since we use grey elsewhere to indicate that menu options are disabled. I might opt for all white, or bold vs. normal, but am open to other ideas.

comment:18 Changed 8 years ago by magnate

I had previously thought of combining quality squelch with knowledge by adding a column to the object knowledge display to show what level of that item is currently squelched (bad, average, etc. etc.).

This opens up new possibilities though: we can finally move towards finer-grained squelching by allowing the player to choose to squelch ego types ... (admittedly that's a different piece of work: #1050).

comment:19 Changed 8 years ago by magnate

  • Keywords special artifact removed

Ok, for clarification: this ticket is about fixing the bug which puts "Amulet" and "Necklace" and "Jewel" in the squelch menu. That means #1273 is about combining the squelch menu with the knowledge menu in a way which preserves people's ability to squelch unaware flavours.

comment:20 Changed 8 years ago by magnate

  • Status changed from assigned to pending

So, the actual bug is fixed in [r6d8c346]. #1273 remains open for the UI change to combine the squelch and knowledge menus.

comment:21 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In master as of [r72e6029], Sun 22 May 2011.

Note: See TracTickets for help on using tickets.