Opened 8 years ago

Closed 7 years ago

#1379 closed bug (fixed (in master))

Ctrl-x should have the same behaviour as the Quit button

Reported by: magnate Owned by: noz
Milestone: 3.3.0 Keywords: sdl
Cc:

Description

According to http://angband.oook.cz/forum/showthread.php?t=4234, the sdlinit.txt file is not updated when you exit with ctrl-x, but is updated when you exit via the Quit button. It would be better if they both wrote out the updated sdlinit.txt file, since ctrl-s ctrl-c can be used to save and exit without doing so, if that is desired.

Change History (4)

comment:1 Changed 8 years ago by magnate

  • Status changed from new to confirmed

comment:2 Changed 7 years ago by noz

  • Owner set to noz
  • Status changed from confirmed to assigned

comment:3 Changed 7 years ago by noz

I cannot confirm this.

Both the Quit button and Ctrl-x call quit(NULL); and the quit handler installed by init_sdl(), hook_quit, calls save_prefs(). This actually means that the SDL Quit button calls save_prefs() twice, but that can be cleaned up.

comment:4 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from assigned to closed

Nor can I any longer, though it was real.

Note: See TracTickets for help on using tickets.