Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1389 closed bug (fixed (in master))

Keymap editor doesn't save '\' properly

Reported by: myshkin Owned by: myshkin
Milestone: 3.3.0 Keywords: InputRework keymap
Cc:

Description

Reported by MaxStats? on oook, and I can confirm it. The keymap editor saves a keymap containing '\' without escaping the backslash, and then the parser interprets the backslash as an escape character.

Change History (5)

comment:1 Changed 7 years ago by mikon

That may be why \r does not work in my TAB -> R&\r macro (which would be nice as default, BTW, as in S or FA, don't remember which).

comment:2 Changed 7 years ago by takkaria

ah, thesedays you need to do R&[Enter] instead of R&\r. But you're right that the keymap editor doesn't escape appropriately.

comment:3 Changed 7 years ago by magnate

  • Owner set to myshkin
  • Status changed from new to assigned

The thread linked in the description now contains a patch from Max Stats. It looks fine to me, but someone else probably ought to have a look at it before it's committed.

comment:4 Changed 7 years ago by myshkin

  • Status changed from assigned to pending

Patch from Max Stats; fixed in staging [19ffe61]. Note that the keymap module does not actually map a bare '\', as that is needed for command escaping, but this commit fixes behavior for keypresses like \.

comment:5 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In master as of [r022d04e]

Note: See TracTickets for help on using tickets.