Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1392 closed bug (fixed (in master))

object origin crash

Reported by: takkaria Owned by:
Milestone: 3.3.0 Keywords: recall
Cc:

Description

game crashes on character dump; oook thread, with savefile attached.

Change History (4)

comment:1 Changed 9 years ago by magnate

  • Keywords recall added
  • Status changed from new to confirmed
  • Summary changed from character dump crash to object origin crash

The bug is not with the chardump, because the crash occurs on examining the maul as well - the maul has an illegal origin byte, somehow. I'm fairly sure I've seen this illegal origin problem before, but may be confusing it with #1254.

comment:2 Changed 9 years ago by myshkin

Turns out that, at least in this case, the origin byte is just fine, but the origin_xtra byte refers to a monster that's been deleted from monster.txt. describe_origin() needs more sanity checking on name.

comment:3 Changed 9 years ago by magnate

  • Status changed from confirmed to pending

[rd3967fb].

comment:4 Changed 9 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In master as of [r72e6029], Sun 22 May 2011.

Note: See TracTickets for help on using tickets.