Opened 9 years ago

Closed 9 years ago

#1416 closed bug (duplicate)

Staff of Detect Invisible not showing invisible monster

Reported by: d_m Owned by:
Milestone: Triage Keywords: magic detection
Cc:

Description

In the attached savefile there is a Moaning Spirit in the room. If you enter debug mode and create (and drink) a potion of True Seeing you'll see it. But no matter how many times you (u)se the staff of Detect Invisible you won't see it.

There was another bug reported earlier which caused detected monsters to stay detected until the player's next move. I'm not sure if that bug was "fixed" but if so then I bet that bug has caused this one. All said, I prefer the player to get a little too much information as opposed to having a device which is (now) completely useless.

Of course, they may be totally unrelated.

Change History (3)

comment:1 Changed 9 years ago by d_m

Of course trac's attachments are broken. The file is at http://plastic-idolatry.com/angband/invis.save

comment:2 Changed 9 years ago by magnate

  • Keywords magic added; invisible removed

I'm pretty sure this is a duplicate of #1413, but I'll leave this open until the latter is fixed, just in case.

comment:3 Changed 9 years ago by magnate

  • Resolution set to duplicate
  • Status changed from new to closed

Yes, it was.

Note: See TracTickets for help on using tickets.