Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#1461 closed bug (fixed (in master))

Game deletes <savefile>.old and <savefile>.new when saving

Reported by: myshkin Owned by:
Milestone: 3.3.1 Keywords: loadsave cleanup
Cc:

Description

Reported by Timo on oook. savefile_save() should use a temporary name generating function (probably mkstemp() on Unix and tmpnam_s() on Windows) instead of clobbering <savefile>.old and <savefile>.new.

Change History (5)

comment:1 Changed 8 years ago by magnate

  • Status changed from new to confirmed

comment:2 Changed 8 years ago by magnate

  • Milestone changed from 3.3.0 to Future

Punting to Future because of lack of owner and imminent release of 3.3.0

comment:3 Changed 7 years ago by magnate

  • Milestone changed from Future to 3.4.0

Thanks to Blubaron for the fix.

comment:4 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from confirmed to closed

comment:5 Changed 7 years ago by magnate

  • Milestone changed from 3.4.0 to 3.3.1
Note: See TracTickets for help on using tickets.