Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1465 closed bug (fixed (in master))

Inventory display bug

Reported by: PowerWyrm Owned by:
Milestone: 3.3.0 Keywords: ui
Cc:

Description

If your character has missiles equipped in the quiver slot and nothing in the inventory, the inventory subwindow will display:

(nothing)
b) in Quiver: n missiles

When using the "i" command, the "in Quiver" line is aligned to the right and out of the screen (because quiver slots are not processed when calculating max name length in show_obj_list).

Change History (3)

comment:1 Changed 7 years ago by magnate

  • Keywords ui added
  • Milestone changed from Triage to 3.3.0
  • Status changed from new to confirmed

Unfortunately this ticket conflates two separate problems. I can reproduce the first bug (quiver uses slot b instead of a when inv is empty), but not the right-align issue.

comment:2 Changed 7 years ago by d_m

  • Status changed from confirmed to pending

These issues are fixed in staging.

comment:3 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In master as of [r5c8f16e]

Note: See TracTickets for help on using tickets.