Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1467 closed bug (fixed (in master))

Weapons with mixed to_hit and to_dam values confuse quality squelching

Reported by: chance2 Owned by: magnate
Milestone: 3.3.0 Keywords: squelch
Cc:

Description

This will normally only happen with weapons that have been cursed with a scroll, since non-artifact weapons aren't naturally created with negative values anymore. If one of the values on the weapon is negative and the other positive (as happens when enchanting it to attempt to break the curse), then if you attempt to use the ignore command, the choice for all weapons like this one (quality squelch) will be "all non-artifact {blunt|pointy} weapons". I described the problem in the forums: http://angband.oook.cz/forum/showthread.php?p=54741#post54741

Change History (4)

comment:1 Changed 7 years ago by magnate

  • Milestone changed from Triage to 3.3.0
  • Status changed from new to confirmed

Confirmed. What should the correct behaviour be? I'd suggest it should be "all good ... weapons", i.e. ignore the negative and assume that either +hit or +dam being positive qualifies as good.

comment:2 Changed 7 years ago by chance2

I originally thought of two possibilities: the one you thought of, and using the sum of to_hit and to_dam (negative=bad, zero=average, positive=good). I think the way you have described it is the way to go, because "good" seems to be used somewhat interchangeably with "magical". Should be a fairly rare occurrence anyway, unless the possibility for items created with negative values is brought back.

comment:3 Changed 7 years ago by magnate

  • Owner set to magnate
  • Status changed from confirmed to pending

[rb9d0163]

comment:4 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In master as of [ref5f4267]

Note: See TracTickets for help on using tickets.