Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1473 closed bug (fixed (in master))

You can't pick anything up if you have no items in your inventory

Reported by: takkaria Owned by:
Milestone: 3.3.0 Keywords: commands
Cc:

Description

To reproduce:

  1. Drop everything you have in your inventory on the floor.
  2. Use 'g' to pick up some of the dropped items.

Expected behaviour: Stuff is picked up.

Actual behaviour: Nothing is picked up with no message.

Change History (4)

comment:1 Changed 7 years ago by noz

With auto-pickup on, items do get picked up.

comment:2 Changed 7 years ago by noz

The locus of this fault is the new code to avoid dead objects being used for auto-repeat. It is throwing out the pickup, because there is no object in the argument.

comment:3 Changed 7 years ago by magnate

  • Keywords commands added
  • Status changed from new to pending

[r9e62a79]

comment:4 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

In master as of [ref5f4267]

Note: See TracTickets for help on using tickets.