Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1479 closed bug (fixed (in master))

Unaware mimics not showing up in the right places

Reported by: magnate Owned by: GabeCunningham
Milestone: 3.3.0 Keywords: monster detection
Cc:

Description

http://angband.oook.cz/forum/showthread.php?t=4534

IIUC the correct behaviour should be:

After becoming aware of the mimic type -

  • appears as a normal monster, i.e. same behaviour as before Gabe's changes

Before encountering the mimic type -

  • shows up in the object list (with a fake flavour)
  • does not show up in the monster list
  • does not show up in Detect Monsters
  • does not show up in monster recall (if seen by ancestors, the entry is there but is not associated with the monster in this game)
  • appears as an object in 'l'ook mode

Change History (5)

comment:1 Changed 3 years ago by magnate

  • Milestone changed from 3.3.0 to Future
  • Status changed from new to confirmed

d_m suggests that the above description will make each mimic only a surprise once each game. To prolong the mimicry, mimics should appear as objects every time they are encountered, until they attack or are attacked. This means using a *different* fake flavour each time they appear - though this requirement could be obviated by *removing* flavours from the object list. This has been talked about before as part of giving less information: instead of "an opal ring" the object list/view just says "a ring" until the ring is in LOS.

Furthermore, Gabe has appeared on the forum to say that making mimics appear as objects is nontrivial, and that the current situation is as he intended. So punting this to Future out of respect for that view.

comment:2 Changed 3 years ago by GabeCunningham

I'm working on this now, and what I settled on was to make mimics mimic things that are always desirable. For example, Ring Mimics now always mimic Rings of Speed. It's a lot easier to do it this way. There is still a potential weird interaction with squelch, which is why I'm picking things that (hopefully!) no one squelches. I should have something ready in a day or two.

comment:3 Changed 3 years ago by GabeCunningham

  • Milestone changed from Future to 3.3.0
  • Owner set to GabeCunningham
  • Status changed from confirmed to assigned

comment:4 Changed 3 years ago by magnate

  • Status changed from assigned to pending

Merged in [rf3c2a6a] - thanks Gabe.

comment:5 Changed 3 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

[r9367950]

Note: See TracTickets for help on using tickets.