Opened 3 years ago

Closed 2 years ago

#1493 closed bug (fixed (in master))

At launch, main Angband window appears beneath OS X menubar

Reported by: myshkin Owned by: myshkin
Milestone: 3.4.0 Keywords: mac
Cc:

Description

Reported a number of times on oook, notably in this thread. After a few restarts of the application, the main Angband window begins spawning at the upper left corner of the screen and cannot be moved except through Spaces. Subwindows are not affected. Moving the main window does not fix the problem for subsequent launches. I have not yet successfully reproduced this behavior.

Change History (2)

comment:1 Changed 3 years ago by myshkin

  • Milestone changed from 3.3.0 to 3.4.0
  • Status changed from new to assigned

Enough people have reported this that I'll set it as confirmed, but since I am having trouble reproducing it, it won't get fixed for 3.3. Punting to 3.4.

comment:2 Changed 2 years ago by myshkin

  • Resolution set to fixed (in master)
  • Status changed from assigned to closed

Closed with the deprecation of the Carbon port. I will happily accept patches to fix the problem, however.

Note: See TracTickets for help on using tickets.