Opened 7 years ago

Closed 7 years ago

#1494 closed bug (fixed (in master))

Bug report: / on numpad on win7

Reported by: Remuz Owned by:
Milestone: 3.3.2 Keywords: windows
Cc:

Description

Copied from http://angband.oook.cz/forum/showthread.php?t=4652:

Hi,

Running the latest RC on windows 7, I noticed that the following usecase does not work:

  • 'I' to examine an item
  • '/' on the numpad to switch to equipment

This works in 3.2, and using the other '/' key works fine, too. It does not matter if numlock is turned on or off.

For the record, I am using a french azerty keyboard. I noticed this bug at home, so I cannot be more specific details here, but if you need more information, I will happily provide them when I get back.

By the way, another rambling. I am used to moving with the numpad, but I cannot "shift-run" if the numpad is turned on. The problem is, when it is off, I cannot use it to provide numbers to the game (in stores, or to drop part of a stack).
I an ideal world, I could run *and* provide numbers to the game whether the numpad is on or off. But this is not new to 3.3, so not technically a bug, more a feature request.

Thanks a lot for your efforts!

Change History (8)

comment:1 Changed 7 years ago by magnate

  • Keywords windows added

I think this may be a duplicate of #620? I cannot reproduce this behaviour in -mgcu under cygwin.

comment:2 Changed 7 years ago by magnate

  • Milestone changed from Triage to 3.3.2
  • Status changed from new to confirmed

Still not sure if this is a duplicate, but trying to fix this in 3.3.2

comment:3 Changed 7 years ago by fizzix

so this is most likely related to #620, but there is odd behavior on my windows XP laptop (no numpad)

Using ctrl+arrow allows me to swing in the direction of the arrow without moving (as is proper). Similarly, ctrl+number works properly only if you are using a cardinal direction (2,4,6,8). For diagonals, the number key does not work. You can bypass this by invoking the windows numpad using the function key. So fun+J simulates 1 on a numpad and ctrl+fun+j does indeed allow you to swing in the 1 direction.

comment:4 Changed 7 years ago by magnate

@Remuz: please can you confirm ASAP whether this bug still exists in the latest RC version of 3.3.2? you can get it from http://buildbot.rephial.org/builds/3.3-release/builds.html

Thanks.

comment:5 Changed 7 years ago by Remuz

Will test it tonight, thanks for the hard work!

comment:6 Changed 7 years ago by magnate

Remuz: ping! Any news on this? 3.3.2 is now ready to release ... final version at the above link ...

comment:7 Changed 7 years ago by Remuz

Sorry for the delay! Both problems are now fixed, thanks a lot for the work!

You can ship. :-)

comment:8 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from confirmed to closed

Yay!

Note: See TracTickets for help on using tickets.