Opened 3 years ago

Closed 13 months ago

#1495 closed bug (fixed (in master))

Visual artifacts in overhead map.

Reported by: jens Owned by:
Milestone: 3.5.0 Keywords: subwindows
Cc:

Description (last modified by takkaria)

The fix for #1265, which removed a frequent redraw of the whole overhead map (commit: 47dd76ae5077c2731920) has left visual artifacts in the overhead map when returning to town.

Thread on Oook: http://angband.oook.cz/forum/showthread.php?p=56817

To recreate the bug: Return to town, either by recall or staircase. The town is drawn on the left side of the map, any old information that is not overwritten remains on the map, so make sure that your overhead map is larger than the town and that you have explored areas to the right in the dungeon, that will not be covered by the town.

I tried several methods to clear the map:

Does not clear the map:

  • Bringing up another program to cover the map.
  • Cover the map with the Angband terminal or another terminal.
  • Minimizing Angband.
  • [CTRL]R
  • Moving map window.
  • Resizing the window, making it bigger.
  • Closing the overhead map and then opening it again, neither by the 'x' in the corner nor the window menu.

Works partly:

  • Resizing the map window, making it smaller: clears the areas that you hide when sizing down, so if you then size it up again the visual artifacts you covered will be gone.

Does work:

  • Toggle the map view off/on.
  • Quitting/reloading.
  • Entering the dungeon.

Change History (3)

comment:1 Changed 3 years ago by magnate

  • Milestone changed from Triage to Future
  • Status changed from new to confirmed

I can confirm this behaviour. To be clear, we are talking about the subwindow which is called "Display overhead view" in the subwindow options menu. I cannot reproduce this behaviour with a subwindow using "Display map view" (because that shows me nothing at all!).

comment:2 Changed 17 months ago by takkaria

  • Milestone changed from Future to 3.5.0

Assigning still-open bugs from Future to 3.5 for fixing.

comment:3 Changed 13 months ago by takkaria

  • Description modified (diff)
  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Fixed in 40d34ad783f54c5e5d41a61e0185577032e51127, thanks.

Note: See TracTickets for help on using tickets.