Opened 7 years ago

Closed 7 years ago

#1507 closed bug (fixed (in master))

Rebalance to-hit vs AC

Reported by: magnate Owned by: magnate
Milestone: 3.3.1 Keywords: combat
Cc:

Description

Prior to the major rewrite implied by #1446, we need to adjust to-hit vs. AC so that it's roughly the same as 2.9.x - Timo provides some helpful analysis here:

http://angband.oook.cz/forum/showthread.php?t=4738

Endgame AC has increased by about 20% (with standarts - randarts need to adhere to this) but the last to-hit changes in 3.3 have overcompensated so AC is now not worth enough against heavy hitters.

Jens has submitted a pull request on github for another pass at fixing this - this needs careful testing in a dev version and then may need further adjustment for 3.3.1

Change History (3)

comment:1 Changed 7 years ago by magnate

  • Status changed from new to confirmed

Jens's fix was merged as [r866a530e] and [rbd780bfe]

comment:2 Changed 7 years ago by magnate

  • Status changed from confirmed to pending

Now pending merge into 3.3-release if it is deemed to have solved the problem.

comment:3 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from pending to closed

Cherry-picked to 3.3-release. No complaints since this was implemented, so maybe it will last until combat is overhauled.

Note: See TracTickets for help on using tickets.