Opened 8 years ago

Closed 8 years ago

#1514 closed change (fixed (in master))

Nerf object detection

Reported by: magnate Owned by: magnate
Milestone: 3.4.0 Keywords: items
Cc:

Description

Further down http://angband.oook.cz/forum/showthread.php?t=4785 there's a solid consensus that Rods of Treasure Detection should be removed, and scrolls should be dungeon-only and come in small stacks (I suggest 1+2d4 or so).

Change History (4)

comment:1 Changed 8 years ago by magnate

  • Milestone changed from 3.3.1 to 3.4.0
  • Status changed from new to confirmed

This was tagged 3.3.1 in error - it's a balance change, not a bugfix.

comment:2 Changed 8 years ago by takkaria

  • Summary changed from Remove -dObj and adjust ?dObj to Nerf object detection

Current suggestions:

  • remove rods of dObj
  • make rods of Detection fuzzy-detect, by just showing the locations of items but not the items themselves
  • make scrolls of dObj dungeon-only but also found in stacks (and maybe fuzz detection?)
  • remove treasure detection abilities of all but rogues (detect enchantment could then become mass-visible-ID)

comment:3 Changed 8 years ago by magnate

  • Milestone changed from 3.4.0 to 4.0

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:4 Changed 8 years ago by magnate

  • Milestone changed from 4.0 to 3.4.0
  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Actually released in v4 and master simultaneously, as of [r6ca2d53] in master and [rc2d5c45] in v4.

Note: See TracTickets for help on using tickets.